Shifter Trim Reassembly Tips
Welcome to the site! Take a minute to register and join us. It's FREE! (and fun)
The ORIGINAL Aztek Fan Club Welcome, Guest. Please login or register.
Did you miss your activation email?
Always stay logged in

Login with username, password and session length
Home Gallery Help Login Register
Pages: [1]   Go Down
  Print  
Author Topic: Shifter Trim Reassembly Tips  (Read 1541 times)
0 Members and 1 Guest are viewing this topic.
andymcclure
Member
*
Offline Offline

Posts: 4


« on: July 29, 2013, 11:12:17 AM »

Most of the dash/shifter/radio trim is currently removed from my 2004 Aztek Rally. (I pulled the instrument cluster for repair.)

Three things:

1 - As long as I have it apart, I thought I'd replace that little bulb under the shifter. Does anyone have any tips for pulling that bulb? I can get the lampholder out of its little notch OK, but actually pulling the bulb out of the holder is proving difficult. I want to avoid crushing the bulb in my fingertips, which would result in tiny pieces of glass in bad places.

2 - Also, when reassembling the shifter, there's that "belt" that slides the orange indicator alongside the P/R/N/D/etc. I've already put that back together for driving while the trim is out, and it doesn't seem quite right. It works, but it's a little noisy/grindy when shifting. It's not bad enough that I think I broke anything or seriously messed it up, but more like it's just not quite in there the right way and it rubs a little.

3 - When I pulled the instrument cluster, I lost the display on the radio (factory CD/MP3 player). I see a lot of people have had similar issues with their radio/clock. Does anyone have a guess as to whether that's out because the cluster is removed or did it just happen to go out while I was in there working? Not a huge deal, but if I'm going to replace the radio, I might as well do it while I've got all the trim out.

Thanks!
Logged
HulkakaJose
100 Club Members
****
Offline Offline

Posts: 117


WWW
« Reply #1 on: July 30, 2013, 11:18:28 AM »

I have replaced my shifter bulb two or three times, yes it seems as if it would break but it has never broken on me before
The belt for the shifter you have to play with it because it is tricky. I don't think you will ever get it back the way it use to be because I've tried numerous times and no luck. The only problem I have with that is the light shining out the side of the P/R/N/D to indicate what you are on doesn't appear on all of them.
For the radio I think your bulbs might have gone out because mine were ok when I put it back together but now one side of the radio/song name is dim and the other side flickers from time to time, I think the only way to fix that is replacing the factory radio.
Hope it helps
Logged
Pages: [1]   Go Up
  Print  
 
Jump to:  

Powered by SMF 1.1.20 | SMF © 2013, Simple Machines
Theme Underground Yellow