Welcome to the site! Take a minute to register and join us. It's FREE! (and fun)
The ORIGINAL Aztek Fan Club Welcome, Guest. Please login or register.
Did you miss your activation email?
Always stay logged in

Login with username, password and session length
Home Gallery Help Login Register
Pages: [1]   Go Down
  Print  
Author Topic: Draw tite Trailer receiver install issue.  (Read 2128 times)
0 Members and 1 Guest are viewing this topic.
PSUAztek717
Intermediate User
**
Offline Offline

Posts: 27


« on: April 02, 2017, 06:38:59 PM »

Need some advice....has anyone put this receiver on thier tek?  

https://www.etrailer.com/Trailer-Hitch/Draw-Tite/75138.html

I cant seem to get the fascia back on and it is not flush with the rest of the body panels.  Did anyone else have this issue?  Should i buy new push pins?  Any advice will help.  Thanks?
Logged

2005 Aztek Fusion Orange Metallic FWD
PSUAztek717
Intermediate User
**
Offline Offline

Posts: 27


« Reply #1 on: April 29, 2017, 09:30:37 PM »

Well, I just went ahead and cut the styrofoam under the bumper fascia and that made it work. just in case anyone has this issue later.
Logged

2005 Aztek Fusion Orange Metallic FWD
Bill Salina
Paid Member
100 Club Members
*****
Offline Offline

Posts: 253


2003 Gold FWD Aztek - aka "The Warthog"


« Reply #2 on: April 30, 2017, 08:53:01 AM »

Sorry, I didn't see this when you posted it...

I'm pretty sure that's the hitch I bought for my Aztek.

I don't remember having a problem getting the fascia back on.

The hitch itself does cause a small bulge on each side where it contacts the fascia though.

I don't tow anything - got my hitch after I discovered that the rear bumper was made of Styrofoam.  I wanted something that would keep the car from getting damaged during low speed impacts.  So far, it's kept 2 jeeps that have hit me from damaging my rear hatch and tailgate. Smiley

I don't remember having to use all that extra hardware.  Only used the bolts.  The frame already had the nuts welded in where the hitch attached.
Logged

Bill (aka Bird Dog)
2003 Gold FWD Aztek "The Warthog"
PSUAztek717
Intermediate User
**
Offline Offline

Posts: 27


« Reply #3 on: April 30, 2017, 11:37:03 AM »

I figured it may just not go back correctly because of the 12 year old plasic expanding and contracting over the years.  But, i got it to at least do the job by cutting the styrofoam back.

Before i cut it back, i went for a weekend camping trip and the stress on the push pins was so bad the right side broke and fell out.  Thankfully i didnt damage anything or lose the fascia. 
Logged

2005 Aztek Fusion Orange Metallic FWD
Pages: [1]   Go Up
  Print  
 
Jump to:  

Powered by SMF 1.1.20 | SMF © 2013, Simple Machines
Theme Underground Yellow