Welcome to the site! Take a minute to register and join us. It's FREE! (and fun)
The ORIGINAL Aztek Fan Club Welcome, Guest. Please login or register.
Did you miss your activation email?
Always stay logged in

Login with username, password and session length
Home Gallery Help Login Register
Pages: [1]   Go Down
  Print  
Author Topic: REALLY dumb question....  (Read 1187 times)
0 Members and 1 Guest are viewing this topic.
Bode13
Intermediate User
**
Offline Offline

Posts: 34


« on: January 13, 2007, 10:57:42 AM »

...and I feel like a complete doorknob for even being in this situation...but a mechanic that is a friend of a friend put the new struts on my Tek a few days ago.  Monroe SensaTrak replacing OEMs.  When I went to pick it up, he said he had trouble with the spring isolators fitting just right.  Said they didn't look like anything he was pulling off the car when taking the old struts off.

Then as we were walking out the door, he looked in the box of parts I had given him along with the struts (upper SI, lower SI, and a mounting kit) and pulled out the lower SI and said, "Hmm, what's this?" as if it was the first time he was seeing it (red flag number 1!).

Then he said, "Oh, I guess I should have put this on the lower end of the spring.  I just left the old upper SI in place, and used the other ring (the new upper SI I had provided) on the lower end of the spring.  But it's okay, it can't contact the strut perch."

Now, at this point I probably should have said, "pull it apart and put it together the right way."  But frankly, I didn't want this guy touching my vehicle anymore after this fiasco.

So, the question is this...what, if any, harm might it do to simply leave it as is...with an upper SI mounted to the lower end of the coil spring?  Is it just a matter of time before the spring shifts and slips off the rubber ring and onto the strut perch?  Or is it really more of a longevity issue (i.e. the upper SI will work fine on the lower end of the spring, but probably won't last as long as a properly installed lower SI would)?

I've already had the alignment done (the mechanic didn't have an alignment rack, so I took it to get it aligned at another place), and of course, if someone pulls those struts off to fix this guy's error, then I'm on the hook for another alignment.

Any advice would be VERY MUCH appreciated before I make a snap (and if my recent track record is any indication BAD) decision.
Logged
Pages: [1]   Go Up
  Print  
 
Jump to:  

Powered by SMF 1.1.20 | SMF © 2013, Simple Machines
Theme Underground Yellow