slow oil leak & possible transmission slipping?
Welcome to the site! Take a minute to register and join us. It's FREE! (and fun)
The ORIGINAL Aztek Fan Club Welcome, Guest. Please login or register.
Did you miss your activation email?
Always stay logged in

Login with username, password and session length
Home Gallery Help Login Register
Pages: [1]   Go Down
  Print  
Author Topic: slow oil leak & possible transmission slipping?  (Read 1008 times)
0 Members and 1 Guest are viewing this topic.
PurplePuppy
100 Club Members
****
Offline Offline

Posts: 154

Purple Puppy (My Royal Aztek)


« on: February 12, 2014, 03:52:52 PM »

Help I have this very slow oil leak I mean it just dribbles like 2 drops on the garage floor.  This has been going on for over a year.  I have my oil changed every 3000 miles or 90 days no matter the mileage.  I had the crankshaft seal replace in June of this year and that wasn't it.  I am scared it is something expensive.  Also sometimes when I put the purple puppy in park he will roll forward a bit.  I can hear his gears changing when I am driving him and it's almost like a little pull or clink - I'm in trouble aren't I?  I can't loose this car - He is my friend and protector I love my car.  My husband died in March of last year.  Then in May my dog Crystal died and on December 28 (not even two months ago) my husbands dog Mr. Bear joined him and his sister crystal in Heaven.  The only family I have left is my bird Heshe and our car Purple Puppy.  Is there anyone who might help with Purple Puppy's problem.

Thank you
Chere McCoy :huh: :huh:
« Last Edit: February 12, 2014, 03:55:12 PM by PurplePuppy » Logged

Chere, Crystal, Bear, Heshe & PurplePuppy (The Royal Aztek)
Dumpy
100 Club Members
****
Offline Offline

Posts: 103



« Reply #1 on: February 19, 2014, 05:35:16 AM »

Hi purplepuppy

IMO don't worry too much about the engine oil drip but have your transmission filter & fluid changed if its not been done in recent memory or 75,000 miles (+/-)

* I'm no expert but I do own a Dodge, hence the tranny awareness
Logged

Yellow 2002 1SB FWD
PurplePuppy
100 Club Members
****
Offline Offline

Posts: 154

Purple Puppy (My Royal Aztek)


« Reply #2 on: February 19, 2014, 09:47:23 AM »

Thanks dumpy.  I had the full maintenance done in June of 2013.  So I've only been 4000 miles since then.  Anyone know what to do to clean up the new and old oil on my cement garage?
Logged

Chere, Crystal, Bear, Heshe & PurplePuppy (The Royal Aztek)
hardwaregrrl
Advanced User
***
Offline Offline

Posts: 65


« Reply #3 on: February 20, 2014, 01:51:19 PM »

Simple green and a stiff brush work well on concrete.  I'm sure Home depot and the like have a few flavors of cleaners.  I've had a mystery oil leak on my aztek for about 3 years....more of a mist.  I check the oil once a month and rarely have to add.   Just for giggles, start the car then pop the hood.  Take a peak straight down on the left side behind the radiator at your oil filter.  It may have a hole in it that only will spray when running.  I've had that happen, rock bounced up and nicked it.  Sorry about your losses.
Logged
Pages: [1]   Go Up
  Print  
 
Jump to:  

Powered by SMF 1.1.20 | SMF © 2013, Simple Machines
Theme Underground Yellow