2004 Aztek AWD - Stalling occasionally when accelerating from stop
Welcome to the site! Take a minute to register and join us. It's FREE! (and fun)
The ORIGINAL Aztek Fan Club Welcome, Guest. Please login or register.
Did you miss your activation email?
Always stay logged in

Login with username, password and session length
Home Gallery Help Login Register
Pages: [1]   Go Down
  Print  
Author Topic: 2004 Aztek AWD - Stalling occasionally when accelerating from stop  (Read 147 times)
0 Members and 1 Guest are viewing this topic.
ftldave
Member
*
Offline Offline

Posts: 3


« on: August 18, 2017, 08:08:13 AM »

My 2004 AWD Aztek has started to occasionally stall when accelerating rapidly from a stop, if I 'punch it' a little bit. Slow gradual acceleration from standing-stop, no stall. Never stalls at any other times, runs without problems in all other driving modes. Starts normally, great acceleration on the road, 17mpg city, otherwise a normal running Tek.

I've had 2 Firestone shops and my local GM dealer try to identify the problem, with no success. Items replaced and tested include throttle position sensor, crankshaft position sensor, idle air control motor, on and on. Wiring harness and grounding wires inspected, all the usual suspects. Same behavior on premium and regular gas, and even after comprehensive tune-up, new plugs, wires. Fuel pressure okay, fuel filters replaced - no joy, no improvement. And, before anyone asks - no codes after it happens, the modern mechanic's bane.

The chumps were stumped, despite their best efforts. Being an intermittent problem doesn't help, i.e. only stalls now and then. And, to their credit, the shops didn't charge me for all the parts they threw at it, so good on them.

While I've come to drive more smoothly, carefully, and slowly in my older age, there are times when a driver needs to accelerate rapidly from a stop. Is this another of the accursed Aztek 'quirks"?


« Last Edit: August 18, 2017, 08:10:33 AM by ftldave » Logged
Pages: [1]   Go Up
  Print  
 
Jump to:  

Powered by SMF 1.1.20 | SMF © 2013, Simple Machines
Theme Underground Yellow