Another Versatrak issue
Welcome to the site! Take a minute to register and join us. It's FREE! (and fun)
The ORIGINAL Aztek Fan Club Welcome, Guest. Please login or register.
Did you miss your activation email?
Always stay logged in

Login with username, password and session length
Home Gallery Help Login Register
Pages: [1]   Go Down
  Print  
Author Topic: Another Versatrak issue  (Read 2378 times)
0 Members and 1 Guest are viewing this topic.
Pontiac6KSTEAWD
100 Club Members
****
Offline Offline

Posts: 314

Car Nut!


« on: November 29, 2015, 10:41:41 PM »

Used the search feature, and not really seeing anything that specificly addresses my issues.

I have had a random AWD disable light on for a few years. it only comes on in the winter, and only after I have signifigant front wheel slippage.

Things replaced/repaired:
I have rewired the C305 connecter as I know it is a problem spot for these cars.
I have also replaced the rear diff fluid with GM Versatrak fluid.
I have also replaced the rear diff actuator.
I also replaced the tires to a new matched set (old set was also matched).

None of these fixes have done anything in keeping this light off. I also know its not a overheating issue as I had it turn on as I was pulling out of my driveway onto the snowpacked road. Engine was cold, and so was diff (IE was 10F out). I have no ABS light on. I have no rear end noises. ABS system works perfectly.

And I am also out of ideas on what to try next....

Any ideas here?
Logged

Brian - Carpe Diem

01 Pontiac Aztek GT OPT AWD 110k - 04 GMC Envoy XUV 150k

neopostman
Advanced User
***
Offline Offline

Posts: 64



« Reply #1 on: December 12, 2015, 09:34:55 AM »

Have you replaced the wheel hubs or checked the electrical connectors?
Logged
Pontiac6KSTEAWD
100 Club Members
****
Offline Offline

Posts: 314

Car Nut!


« Reply #2 on: December 13, 2015, 02:19:41 PM »

With no ABS light on, and no TCS light on, and with the ABS working perfectly, i don't see how that would help.
Logged

Brian - Carpe Diem

01 Pontiac Aztek GT OPT AWD 110k - 04 GMC Envoy XUV 150k

Pontiac6KSTEAWD
100 Club Members
****
Offline Offline

Posts: 314

Car Nut!


« Reply #3 on: April 09, 2017, 12:45:23 PM »

So, after the dealer took a look at it. We determined that at some point before I bought it, it was towed, with only the front wheels of the ground, which burnt up the clutches. Bought a new/used unit today, and going to have a shop install it.
Logged

Brian - Carpe Diem

01 Pontiac Aztek GT OPT AWD 110k - 04 GMC Envoy XUV 150k

Pages: [1]   Go Up
  Print  
 
Jump to:  

Powered by SMF 1.1.20 | SMF © 2013, Simple Machines
Theme Underground Yellow