Welcome to the site! Take a minute to register and join us. It's FREE! (and fun)
The ORIGINAL Aztek Fan Club Welcome, Guest. Please login or register.
Did you miss your activation email?
Always stay logged in

Login with username, password and session length
Home Gallery Help Login Register
Pages: [1]   Go Down
Author Topic: My Aztek is dead...  (Read 1575 times)
0 Members and 1 Guest are viewing this topic.
Intermediate User
Offline Offline

Posts: 23

"The RoadTek"

« on: July 27, 2017, 05:18:47 AM »

Yesterday at 4:27pm EST, the Aztek once again overheated. I was 2 miles away from work and had a friend bring his Dirtymax and tow me home on a trailer. When we got home, the engine refused to turn over. I got her started up, and the starter and all electrical wiring was extremely hot to the touch. Once we got her off the trailer, she started to billow white smoke. The head gasket popped and the engine was done.

2002 Aztek AWD

22" Light Bar
2 Baja Driving lights
c305 Ectomy

Brush Guard
Front Hitch
Bigger Tires - ATs
Bedliner moldings
Bill Salina
Paid Member
100 Club Members
Offline Offline

Posts: 252

2003 Gold FWD Aztek - aka "The Warthog"

« Reply #1 on: July 29, 2017, 09:41:07 AM »

Majora097 - really sorry to hear that.

Did you have any warning before it happened?   Any idea what caused the overheating?

Again, really sorry to hear this. 

I hope you're able to fix it (either by replacing the engine or the head gasket).

Bill (aka Bird Dog)
2003 Gold FWD Aztek "The Warthog"
Pages: [1]   Go Up
Jump to:  

Powered by SMF 1.1.20 | SMF © 2013, Simple Machines
Theme Underground Yellow