The ORIGINAL Aztek Fan Club

AZTEK GARAGE (Peer Support) => MECHANICAL/ELECTRICAL/OTHER => Topic started by: AbsentbebniM on July 08, 2018, 12:54:24 PM



Title: Re-calibrate temp gauge after stepper motor replacement?
Post by: AbsentbebniM on July 08, 2018, 12:54:24 PM
I recently replaced the stepper motor for the temp gauge and it does not stay where it belongs. All of the other gauges are working as they should after their swap, but this one drifts below the C unless I physically hold it at there when I turn the key. I even went as far as putting the old stepper back in to see if thatd fix it... but nope. Before I tap some sort of pin in at the C to hold it, Id like to know if there is a way to correct the issue. Thanks for any assistance you can provide.


Title: Re: Re-calibrate temp gauge after stepper motor replacement?
Post by: Tronman on July 17, 2018, 11:01:55 PM
I'm watching this with some interest as my temp gauge hasn't worked for ages.  And with those shiny new heads n gaskets, I figure now is a good time to repair it because it's cumbersome to use my scan tool as a temp gauge..

Where'd you get the stepper motors?


Title: Re: Re-calibrate temp gauge after stepper motor replacement?
Post by: AbsentbebniM on July 18, 2018, 08:45:32 PM
I was actually able to correct it. It seems I somehow didnt have the stepper motor adjusted so it hit its limit at the C. I feel a bit dumb, but its the one gauge that goes counterclockwise, so Ill give myself a pass.

Im not sure how long this link will work, but I purchased my stepper motors as part of a kit with replacement red LEDs...

https://rover.ebay.com/rover/0/0/0?mpre=https%3A%2F%2Fwww.ebay.com%2Fulk%2Fitm%2F112927875473 (https://rover.ebay.com/rover/0/0/0?mpre=https%3A%2F%2Fwww.ebay.com%2Fulk%2Fitm%2F112927875473)

Half of the original incandescent bulbs installed on the cluster had either burnt out or had failed connections that made them work sporadically, so nighttime driving was a pain. Since the stepper motors are known to go out as well, and I was already going to have the cluster removed, I decided to swap everything.

If youre handy with a soldering iron, the process is easy enough... though some guesswork may be needed with determining + (pos) and - (neg) for the LEDs.