Welcome to the site! Take a minute to register and join us. It's FREE! (and fun)
The ORIGINAL Aztek Fan Club Welcome, Guest. Please login or register.
Did you miss your activation email?
Always stay logged in

Login with username, password and session length
Home Gallery Help Login Register
Pages: [1]   Go Down
  Print  
Author Topic: 3.4L V6 Rebuild Pt.3  (Read 7353 times)
0 Members and 1 Guest are viewing this topic.
Wolfy1969
Moderator
100 Club Members
*****
Offline Offline

Posts: 197


« on: July 02, 2011, 11:41:20 AM »

Almost there - other mounting bracket is installed, oil filter is in place (after retrieving the threaded adapter post from the old block)...



Front end -  old power steering pump in place, brand new alternator, new 2nd idler pulley, new belt tensioner.  New belt too, but I can't put it on because the A/C Compressor is still with the car body.



Left side - Ignition module and coil packs in place..



Back



Top view from left side:



The completed engine in sections as it looks in the Tek:

Front (upper)



Front (lower) new motor mount installed



Left (belt side) new motor mount



Back (lower) all the stuff you can't see when it's in the car...



Back (3/4) where the tranny bolts up.



Front (3/4) where the tranny bolts up.





Logged
Throttle Jockey
Guest
« Reply #1 on: August 11, 2011, 05:33:48 PM »

All I can say is, “I'm glad you have the patients”. I replaced my radiator, cooling pump, and thermostat. I thought I was going to have a meltdown. I give you credit. Your engine does look good.
Logged
Pages: [1]   Go Up
  Print  
 
Jump to:  

Powered by SMF 1.1.20 | SMF © 2013, Simple Machines
Theme Underground Yellow